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Tutorial – Mono-Ridge Metal Roof 
 

Overview of Process 
 
A job typically arrives as a hardcopy drawing or a CAD file – usually as a DWG.  As CAD file formats are so 
varied, we recommend that you request DXF format over DWG – the format of DXF does not change and we 
can always open a DXF file.   
 
Open the DXF and extract critical measurements.  In this case, the building is 25,000 long by 7,700 wide.  The 
roof pitch is 8°.  There are no over-hangs or barge extensions. 
 
The roof has a standard 1000 wide panel and purlins/battens at 1500 centres, with polycarbonate/FRP roof 
lights at selected locations.  Also fitted are several spinning type ventilators. 
 
The building also has an awning on the high side along the full length at 2630 high with 1000 wide cladding 
panels, selected panels with contrasting finish colour. 
 
That describes our building now let’s get to preparing our quotation. 
 
This Tutorial must be read in conjunction with the Reference Manual and the Setup Guide supplied 
with the software. 
 
 

Step 1 – Check material definitions. 
 
Before materials can be estimated, they must be correctly defined.  They would typically be defined in the 
following order to ensure that everything needed was available for use.  For specific detailed instructions 
refer to the Setup Guide. 
 
Fasteners – Different fastener types will be required for fixing the purlin/battens, the roof sheets and the trim 
plus on occasions a stitch screw is need for the panel seam. 
 
Flashing and Trim – Check that the required trim has been defined and any accessory items associated with 
that trim.  In our case we need an Apron flashing also referred to as a Roof to Wall flashing.  We define 
purlins/battens under the Flashing and Trim section.  Check that the required batten has been correctly 
defined.   
 
In both cases ensure that the correct estimation method has been set as this has a dramatic effect on the cut 
list if not correctly defined.  In our case they will be set to “Total Run into Stock Lengths”.  Select the required 
fastener. 
 
Panels or Sheets – For this job we need two types of panel – a regular metal panel and a polycarbonate or 
FRP panel.  Both panels will be the same cover width of 1000mm.  Note the requirement for setting minimum 
and maximum panel lengths.  A zero length allows the software to create a cut list with the shortest panel 
being as small as 1mm and unlimited maximum length.  If the job requires a 75,000 panel, the cut list will 
specify it.  Select the required fastener. 
 
Metal Colours - If the panels are painted, then you might also need to check the list of paint colours to see 
that your required colour has been defined. 
 
Installer’s Pay Rates – You may define as many different pay rates as you need if you use the Pay Rates – 
Variable options.  Typically, you might have different rates for different trades or different sub-contractors. 
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Step 2 – Create the 3D Roof model. 
 
Using the dimensions provided, and the Cover > Track Plane function (Track Outline generates a hip roof; 
Track Plane a single pitch roof). 
 

    and the Roof Plane Boundary dialog box is displayed. 
 

 
 
Insert R25000 in the Direction field and select Enter or click Insert.  Then D7700 and Enter; the select Close 
and Close Square or just type C and Enter.  The outline is closed out and the perimeter complete. 
 
The closing is and important step for complex roof shapes as it provides a method of checking that the outline 
is correct.  This is especially useful on field measured jobs. 
 
The select Finish or type F and Enter.  The Roof Defaults dialog is displayed. 
 
 

 
 
Set the pitch to 8° and the evae height to the required amount and 
select OK.  A cross hair cursor and the prompt ‘Locate Pitching 
Line’ is displayed.  The pitching line is the line that defines the eave 
or low point of the roof.  The line that roof pitches from. 
 
Select the lower 25000 line.  The roof is created and the roof is 
displayed with lines indicating a metal roof type has been selected 
and falling the bottom of the screen.  You are prompted to save the 
model – save it to a Database File called Training and the model 
name Monoridge1. 
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If you change view to an Isometric view you will see that a true 3D model of your roof has been created from 
the basic information. 
 
Step 3 – Check the model for accuracy 
 
It is no use preparing a quotation if the information is incorrect, so we use the basic tools to check that our 
model is correct before we start applying our materials.   
 
The usual checking tools are: 

• Show Line Types  
• Dimension Roof – Overall 
• Dimension Roof – Lengths 
• Check Roof Pitch and Storey 

  
The Tools > Show Line Types allows us to check that the line 
has the correct flashing category assigned to it.  The software 
makes its best guess and while most of the time it is correct, you 
may require a different style on a line.  Remember, the line type 
is just that – it is not calculating flashing material at this stage. 
 
The Tools > Dimension Roof function has several options: 
The Overall dimension is inserted using Auto-Insert Dimensions 
and are the dimensions of the roof including overhangs, so if you 
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added overhang to the wall dimension, then this has been added.  The Lengths dimensions inserted using 
Insert Line to Line and are the dimensions up the slope of the roof.  This is more noticeable on a hip roof that 
the model we are currently working on. 
 
It is useful to check the roof pitch as it is this that determines the length of our roof sheet.  Use Tools > Show 
Pitch to verify correct roof pitch.  It also displays the storey number.  The storey number is tied in with the pay 
scale for installation, if that is the method of pricing that you have used.   
 

Step 3 – Insert Battens/Purlins 
 
Battens are defined as under the category of Flashings – Def-Materials > Flashing.  An example might look 
something like this: - 
 

 
 
To apply to the roof, go to Cover > Flashing and the following Select/Generate Roof Batten and Trim dialog 
box is displayed.  Select the Batten 1 button, then select the required batten from your defined list of options 
for batten. 
 
Once selected the item description will be displayed. Now click the Insert/Modify button to set the required 
batten spacing for your roof. 
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The Insert/Modify button brings up the following dialog box:  
 

 
 
Here you set the required spacing for the job – working closest to eave and up the roof, then intermediate 
spacing and finally from the ridge back down the roof.  If you do not have subsequent spacings, set to zero as 
shown.  The intermediate spacing may be Fixed Spacing, or Even Spacing up to a maximum intermediate 
spacing. 
 
On this style of work, the remaining options for battens are not normally required, so set to No. 
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Once defined, select the Apply-All button and the battens are drawn on the roof according to your definition, 
as shown below. 
 

 
 

Step 4 – Generate Roof Panels 
 
Now that we have the battens installed, we can install our roof sheets.  The best method for this style of roof is 
Gen-Panels.  This assumes that your panel has been defined as described above and when selected looks 
something like the screen at right: 
 
The important number to get correct is the Coverage 
Width, which is 1000 in this case. 
 
Once selected, click OK and check the parameters 
that have been used to define the panel, then click 
OK. 
 
Now select Estimate > Generate Panel Layout > 
Generate Panels from the Pulldown menu. 
 
A lay direction arrow is drawn and the panels 
generated across the width of the roof. 
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The designer has specified certain panels to be fitted with FRP or polycarbonate roof-lights.  Then these need 
to be defined as a panel as well.  This is done under Def-Materials > Metal Panels also (as they are to be 
fitted with metal panels.  They must be the same width as the metal panel being used. 

 
To fit them to the roof, the currently selected metal panels must be split to fit the 
FRP panels and the split is typically over successive battens.  To do this we use 
Estimate > Generate Panel Layout > Modify Panels. 
 
Select the Split-Panels option and the Panel Splitting dialog is displayed. 
  

                   

 
 
Set the Overlap and Underlap amounts and check that the method of application is for individual panels (as 
we do not need to split the entire job in this example); and then “Insert a new panel between battens” option. 
 
The individual panels are all filled in and the battens displayed.  Select the top and bottom batten where it is to 
split at then the panel to split.  All panels in the sequence may be selected at once.   
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The currently selected panel is displayed with 
an option to Change Panel.   
 
Select this button and then select the previously 
defined Polycarbonate or FRP panel and OK.  
The new panels are inserted and changed to 
the FRP material. 
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Once all have been selected, right click the mouse to indicate that the process is complete and then select the 
Show-All-Panels and the panels are displayed. 
 

    
 
Select OK and the process is complete.   
 
Now select Estimate > Generate Panel Layout > Tally Panels and you will have a cut list for all products on 
that roof.  Below is the cut list for the FRP panels and the panels are displayed on our model.  Selecting the 
down-arrow next to the list gives the option to review the list for each material type on the roof. 
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The operator has total confidence that the correct panels are installed in the correct location.  Each panel in 
the cut-list has a unique identifier and we know where on the roof it is to be installed.  This information 
matches the cutting list generated as one of the printed reports. 
 

 
 

Step 5 – Trim, Fixtures and Fittings. 
 
 
Fixtures 
 
Any manner of roof fixture from skylights, access hatches to ventilators can be defined and added to the roof.  
Refer to the Reference Manual for the steps to defining a Fixture. 
 
Once defined, they may be added wherever you need them on the roof.  They usually are represented by a 
symbol, but may be drawn to exact scale with as much detail as you think you 
need.  The symbol may also be imported as a CAD file using File > Import > 
DXF. 
 
Save them to a folder that is easy to find in the \User folder – we use Fixtures.dab. 
 
In our example, add three ventilators where required.  In the process of defining 
the fixture, associating the graphic to it, you will also have added the required 
material to trim it off.  Having also defined clips and accessories with the trim, 
these will be included in the take-ff automatically.  The symbol below is what we 
used for a ventilator.  You can draw any symbol you wish to represent the part to 
be installed. 
 
Once ‘installed’ on the roof, we are done with these.  The roof will show them with the symbol you defined, 
similar to the sketch below: 
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The fixtures and all accessory bits such as trim and trim accessories will be included when we Report the job. 
 
 
Flashing and Trim 
 
The last thing to do is apply the trim – the gutters and capping.  These have been previously been defined 
under Def-Materials > Flashing.  Refer to the Setup Guide for more details on setting up the flashing and 
accessories. 
 
To ensure that you get the right trim on the right part of the roof, you must check the line types.  It is the line 
type that determines the trim that is applied to which line.  Every line in an AppliCad has a tag which identifies 
its purpose.  Use Tools > Show Line Types to see what line is what. 
 
 
 
When we Zoom > Window into the area at 
the front of the roof in our example, we can 
see that the default for the bottom edge has 
been defined as a Fascia and Gutter line.  
Other line types are also displayed.  If the 
drawing is getting too busy with information, 
use Tools > Set Display to turn features on 
and off before you show line types. 
 
 
 
Here we have turned off Battens and Sheets to make the drawing easier to interpret.  The default line type at 
the eave is determined by the software based on the settings used when the roof is defined.  The line types 
everywhere else are determined by the geometry of the roof.   
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Each gable end will be identified as Gable End which would typically have rake or barge cap installed.  The 
high side may be an apron (also known as Roof to Wall) if installed next to an existing building.  If it is free 
standing then the top edge would be a ridge cap or more specifically a mono-ridge (where the ridge is formed 
at a tighter angle). 
 
Use Tools > Change Entity > Line Type to set the lines to what is required, if necessary.  
 
Once set, you are ready to apply material to the lines. 
 
Select the Cover > Flashing option (as you did above to install the Battens).   Now you deal with the line 
types listed.  Select each line type in turn and select the required material from the list of previously defined 
trim options.  You should end up with a list similar to that below: 
 

 
 
Allowances button Generate button   Save Button 
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If this list is likely to be a regular setup for your roof system, then you can save this for future use – click the 
Save-As button and define a new name.  This list will be saved as a ‘trim system’ for future use on similar 
jobs. 
 
Part of the process of selecting your trim items is to check the allowances that must be applied to the process 
of generating the cutting list.  Select the Allowances button and set the allowances that work for your product 
and roof system.  You may then save this set of allowances and in so doing, create different allowance files 
the various roof systems in use.   Below is a typical set of allowances.  There is no standard for allowances as 
such – you set what works for your profiles and sections. 
 

 
 
Once the allowances have been set, select OK and the Trim screen is displayed again.  Now select 
Generate.  The software then applies the allowances to the lines and calculates the quantity of material, and 
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the appropriate accessories for that material.  The entire cutting list is displayed and the roof plan drawing is 
annotated with the information about each piece.  Select the Accessories button, and all the accessory 
components are also listed. 
 

     
 
The annotation on the roof plan shows how pieces of what length based on how it is supplied to the job, ie 
how it is manufactured. 
 
 

 
 
 
At this time, the quotation is all but complete.   
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Step 4 – Reporting and Material Lists 
 
The final step in producing a quotation is to select Reporting > Supply and 
Install.  This processes all the data in the job to create the summary of material 
costs and labour costs.  The labour costs will have been defined ahead of time too.  
These are selected when the material is selected.  Labour rates may also be 
defined with the material and will be displayed when the material is selected. 
 
Please refer to the Reference Manual for more details on setting up pay rates. 
They are defined by selecting the Set Up Costing Rates option. 
 
 

 
 
Miscellaneous materials may be added to the list of materials.  These materials are typically items that you 
carry in inventory, are not a function of the roof size or shape, they are just things you need, such as Bin Hire.  
Things that you need on the job, and know the cost of.  These are defined under Materials > Misc Items and 
selected under the Misc-Items button. 
 
The Add-Other button allows you to add anything at all to the quotation.  Such things that you might include 
here are such things as site clean, or site preparation etc. 
 
The Reference Manual explains in much more detail, the rest of the buttons on this box.  The most usual step 
after adding required materials is the Print button. You have many reporting options and you simply select the 
particular report you need for this job at the stage you’re at. 
 
Notice that you have an option to show any line items in your quotation that have been determined to have 
zero quantity (they may have been defined and preselected as an Extra Item, but not required on this job). 
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The appearance, content and style of the standard Templates are defined by the operator to suit the 
requirements of the business.  Defining and modifying Templates is covered in detail in the Reference Manual 
and a Tutorial on the AppliCad website under the Support page. 
 

 
 
 
This process can be used to handle a simple job such as the one we have just completed right through to 
more complex estimating of jobs such as the one shown below: 
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Note: The secret to success of your use of AppliCad, is in the 
preparation and definition of the material lists and pricing files.  
You should be aware that this may be largely completed in 
Microsoft Excel if you have confidence in the use of Excel or 
any other spreadsheet system that views and edits *.CSV flat 
files.   The model of the roof is the ‘bones’ or skeleton upon 
which the pricing is completed.  Once the part definition is 
complete, an accurate 3D model becomes the start of the bid 
process.  Accuracy is key, and once understood, your material 
lists and order forms will be exactly what is required to cover 
the roof. 
 
 
 
The original sketch of this roof included an awning or head 
board.  This may be completed by drawing it as a flat roof and 
applying materials etc as described above; or by using the 
optional Wall cladding module supplied by AppliCad.  If the 
wall module is installed (what we call Warlock) then refer to 
the Reference Manual for details on completing the estimate 
including the wall panels and trim. 
 
At this stage you also have the option of printing various 
drawing reports which includes a roof plan, flashing layout 
plan etc.  Some examples are shown below. 
 
 
 
Summary 
 
It will be observed that the primary purpose of the AppliCad 
software is preparing complete quoting and job management 
information for roofing and cladding as accurately and as 
efficiently as we can – right down to the last nut, bolt and 
screw. 
 
Automatic tools have been created to speed up and improve 
the accuracy of this process.  The automatic functions are not 
designed to produce fabrication or erection detail information. 
 
Having stated this however, be aware that a full function 3D 
CAD program is installed and underpins the whole AppliCad 
process and is available to the operator to produce any 2D 
drawing or 3D model of anything you may conceive from an 
ant farm to space shuttle. 
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Sheet layout 

 
 
Sheet Cutting List 
 

       
 
Isometric View of Roof 

 


